You can use Chrome, Firefox, Safari or Internet Explorer (11 or newer). 

Did this answer your question?